What’s Vulnerable › Vulnerabilities
CVE-2022-1755: SVG Support < 2.5 - Author+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The SVG Support WordPress plugin before 2.5 does not properly handle SVG added via an URL, which could allow users with a role as low as author to perform Cross-Site Scripting attacks
Affected products
- benbodhi SVG Support: before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: benbodhi SVG Support 2.5.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/62b2548e-6b59-48b8-b1c2-9bd47e634982
- https://wpscan.com/vulnerability/62b2548e-6b59-48b8-b1c2-9bd47e634982
Get alerted when CVE-2022-1755 or the next vulnerability affects your stack