What’s Vulnerable › Vulnerabilities
CVE-2022-1757: Pagebar < 2.70 - Arbitrary Settings Update via CSRF to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The pagebar WordPress plugin before 2.70 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack. Furthermore, due to the lack of sanitisation in some of them, it could also lead to Stored XSS issues
Affected products
- pagebar: before 2.70 — fixed in 2.70
How to fix
Upgrade to a fixed version: pagebar 2.70. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e648633e-868b-45b2-870a-308a2f9cb7f5
- https://wpscan.com/vulnerability/e648633e-868b-45b2-870a-308a2f9cb7f5
Get alerted when CVE-2022-1757 or the next vulnerability affects your stack