What’s Vulnerable › Vulnerabilities
CVE-2022-1766
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-20 · updated 2026-06-17
- Weakness: CWE-522
Description
Anchore Enterprise anchorectl version 0.1.4 improperly stored credentials when generating a Software Bill of Materials. anchorectl will add the credentials used to access Anchore Enterprise API in the Software Bill of Materials (SBOM) generated by anchorectl. Users of anchorectl version 0.1.4 should upgrade to anchorectl version 0.1.5 to resolve this issue.
Affected products
- Anchore: before 4.0.1 — fixed in 4.0.1
- Anchorectl: before 0.1.5 — fixed in 0.1.5
How to fix
Upgrade to a fixed version: Anchore 4.0.1; Anchorectl 0.1.5. Check the vendor advisory for mitigations.
References
- https://docs.anchore.com/current/docs/releasenotes/401/
- https://docs.anchore.com/current/docs/releasenotes/401/
Get alerted when CVE-2022-1766 or the next vulnerability affects your stack