What’s Vulnerable › Vulnerabilities
CVE-2022-1770: Improper Privilege Management in polonel/trudesk
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-269
Description
Improper Privilege Management in GitHub repository polonel/trudesk prior to 1.2.2.
Affected products
- polonel/trudesk: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: polonel/trudesk 1.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/polonel/trudesk/commit/889876f66c9a5b28f019258e329310c31d72cbd2
- https://huntr.dev/bounties/74a252a2-8bf6-4f88-a180-b90338a239fa
- https://github.com/polonel/trudesk/commit/889876f66c9a5b28f019258e329310c31d72cbd2
- https://huntr.dev/bounties/74a252a2-8bf6-4f88-a180-b90338a239fa
Get alerted when CVE-2022-1770 or the next vulnerability affects your stack