What’s Vulnerable › Vulnerabilities
CVE-2022-1771: Uncontrolled Recursion in vim/vim
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-18 · updated 2026-06-17
- Weakness: CWE-674
Description
Uncontrolled Recursion in GitHub repository vim/vim prior to 8.2.4975.
Affected products
- vim/vim: before 8.2.4975 — fixed in 8.2.4975
How to fix
Upgrade to a fixed version: vim/vim 8.2.4975. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/51f0bfb88a3554ca2dde777d78a59880d1ee37a8
- https://huntr.dev/bounties/faa74175-5317-4b71-a363-dfc39094ecbb
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/51f0bfb88a3554ca2dde777d78a59880d1ee37a8
- https://huntr.dev/bounties/faa74175-5317-4b71-a363-dfc39094ecbb
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-1771 or the next vulnerability affects your stack