What’s Vulnerable › Vulnerabilities
CVE-2022-1772: Google Places Review < 2.0.0 - Admin+ Stored Cross Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Google Places Reviews WordPress plugin before 2.0.0 does not properly escape its Google API key setting, which is reflected on the site's administration panel. A malicious administrator could abuse this bug, in a multisite WordPress configuration, to trick super-administrators into viewing the booby-trapped payload and taking over their account.
Affected products
- Google Places Reviews: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Google Places Reviews 2.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/02addade-d191-4e45-b7b5-2f3f673679ab
- https://wpscan.com/vulnerability/02addade-d191-4e45-b7b5-2f3f673679ab
Get alerted when CVE-2022-1772 or the next vulnerability affects your stack