What’s Vulnerable › Vulnerabilities
CVE-2022-1775: Weak Password Requirements in polonel/trudesk
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-521
Description
Weak Password Requirements in GitHub repository polonel/trudesk prior to 1.2.2.
Affected products
- polonel/trudesk: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: polonel/trudesk 1.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/polonel/trudesk/commit/13dd6c61fc85fa773b4065f075fceda563129c53
- https://huntr.dev/bounties/0966043c-602f-463e-a6e5-9a1745f4fbfa
- https://github.com/polonel/trudesk/commit/13dd6c61fc85fa773b4065f075fceda563129c53
- https://huntr.dev/bounties/0966043c-602f-463e-a6e5-9a1745f4fbfa
Get alerted when CVE-2022-1775 or the next vulnerability affects your stack