What’s Vulnerable › Vulnerabilities
CVE-2022-1776: Icegram < 2.1.8 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Popups, Welcome Bar, Optins and Lead Generation Plugin WordPress plugin before 2.1.8 does not sanitize and escape some campaign parameters, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
Affected products
- icegram Popups, Welcome Bar, Optins And Lead Generation Plugin: before 2.1.8 — fixed in 2.1.8
How to fix
Upgrade to a fixed version: icegram Popups, Welcome Bar, Optins And Lead Generation Plugin 2.1.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/46ed56db-9b9d-4390-80fc-343a01fcc3c9
- https://wpscan.com/vulnerability/46ed56db-9b9d-4390-80fc-343a01fcc3c9
Get alerted when CVE-2022-1776 or the next vulnerability affects your stack