What’s Vulnerable › Vulnerabilities
CVE-2022-1777: Filr - Secure Document Library < 1.2.2.1 - Subscriber+ AJAX Calls
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-13 · updated 2026-06-17
- Weakness: CWE-862
Description
The Filr WordPress plugin before 1.2.2.1 does not have authorisation check in two of its AJAX actions, allowing them to be called by any authenticated users, such as subscriber. They are are protected with a nonce, however the nonce is leaked on the dashboard. This could allow them to upload arbitrary HTML files as well as delete all files or arbitrary ones.
Affected products
- Filr – Secure document library: before 1.2.2.1 — fixed in 1.2.2.1
How to fix
Upgrade to a fixed version: Filr – Secure document library 1.2.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a50dc7f8-a9e6-41fa-a047-ad1c3bc309b4
- https://wpscan.com/vulnerability/a50dc7f8-a9e6-41fa-a047-ad1c3bc309b4
Get alerted when CVE-2022-1777 or the next vulnerability affects your stack