What’s Vulnerable › Vulnerabilities

CVE-2022-1783

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.3 before 14.9.5, all versions starting from 14.10 before 14.10.4, all versions starting from 15.0 before 15.0.1. It may be possible for malicious group maintainers to add new members to a project within their group, through the REST API, even after their group owner enabled a setting to prevent members from being added to projects within that group.

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.10.4, 14.9.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-1783 or the next vulnerability affects your stack