What’s Vulnerable › Vulnerabilities
CVE-2022-1785: Out-of-bounds Write in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-19 · updated 2026-06-17
- Weakness: CWE-787
Description
Out-of-bounds Write in GitHub repository vim/vim prior to 8.2.4977.
Affected products
- Debian Linux: 10.0
- vim/vim: before 8.2.4977 — fixed in 8.2.4977
How to fix
Upgrade to a fixed version: vim/vim 8.2.4977. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/e2bd8600b873d2cd1f9d667c28cba8b1dba18839
- https://huntr.dev/bounties/8c969cba-eef2-4943-b44a-4e3089599109
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/e2bd8600b873d2cd1f9d667c28cba8b1dba18839
- https://huntr.dev/bounties/8c969cba-eef2-4943-b44a-4e3089599109
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-1785 or the next vulnerability affects your stack