What’s Vulnerable › Vulnerabilities
CVE-2022-1791: One Click Plugin Updater <= 2.4.14 - Arbitrary Settings Update via CSRF
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-13 · updated 2026-06-17
- Weakness: CWE-352
Description
The One Click Plugin Updater WordPress plugin through 2.4.14 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack and disable / hide the badge of the available updates and the related check.
Affected products
- One Click Plugin Updater: through 2.4.14
References
- https://wpscan.com/vulnerability/5c185269-cb3a-4463-8d73-b190813d4431
- https://wpscan.com/vulnerability/5c185269-cb3a-4463-8d73-b190813d4431
Get alerted when CVE-2022-1791 or the next vulnerability affects your stack