What’s Vulnerable › Vulnerabilities
CVE-2022-1798: Path Traversal vulnerability in Kubevirt
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-15 · updated 2026-06-17
- Weakness: CWE-20
Description
A path traversal vulnerability in KubeVirt versions up to 0.56 (and 0.55.1) on all platforms allows a user able to configure the kubevirt to read arbitrary files on the host filesystem which are publicly readable or which are readable for UID 107 or GID 107. /proc/self/<> is not accessible.
Affected products
- kubevirt: from 0.20.0 before 0.55.1 — fixed in 0.55.1
How to fix
Upgrade to a fixed version: kubevirt 0.55.1. Check the vendor advisory for mitigations.
References
- https://github.com/kubevirt/kubevirt/security/advisories/GHSA-qv98-3369-g364
- https://github.com/kubevirt/kubevirt/security/advisories/GHSA-qv98-3369-g364
Get alerted when CVE-2022-1798 or the next vulnerability affects your stack