What’s Vulnerable › Vulnerabilities
CVE-2022-1802
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 28.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-1321
Description
If an attacker was able to corrupt the methods of an Array object in JavaScript via prototype pollution, they could have achieved execution of attacker-controlled JavaScript code in a privileged context. This vulnerability affects Firefox ESR < 91.9.1, Firefox < 100.0.2, Firefox for Android < 100.3.0, and Thunderbird < 91.9.1.
Affected products
- Mozilla Firefox: before 100.0.2; before 100.3.0 — fixed in 100.0.2, 100.3.0
- Mozilla Firefox ESR: before 91.9.1 — fixed in 91.9.1
- Mozilla Thunderbird: before 91.9.1 — fixed in 91.9.1
How to fix
Upgrade to a fixed version: Mozilla Firefox 100.0.2, 100.3.0; Mozilla Firefox ESR 91.9.1; Mozilla Thunderbird 91.9.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1770137
- https://www.mozilla.org/security/advisories/mfsa2022-19/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1770137
- https://www.mozilla.org/security/advisories/mfsa2022-19/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1770137
Get alerted when CVE-2022-1802 or the next vulnerability affects your stack