What’s Vulnerable › Vulnerabilities
CVE-2022-1803: Improper Restriction of Rendered UI Layers or Frames in polonel/trudesk
- Severity: medium (CVSS 6.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-1021
Description
Improper Restriction of Rendered UI Layers or Frames in GitHub repository polonel/trudesk prior to 1.2.2.
Affected products
- polonel/trudesk: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: polonel/trudesk 1.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/polonel/trudesk/commit/6ea9db7a5cf300e3cbf0eab7e1d6da1155a2f7f8
- https://huntr.dev/bounties/47cc6621-2474-40f9-ab68-3cf62389a124
- https://github.com/polonel/trudesk/commit/6ea9db7a5cf300e3cbf0eab7e1d6da1155a2f7f8
- https://huntr.dev/bounties/47cc6621-2474-40f9-ab68-3cf62389a124
Get alerted when CVE-2022-1803 or the next vulnerability affects your stack