What’s Vulnerable › Vulnerabilities
CVE-2022-1812: Integer Overflow or Wraparound in publify/publify
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 30.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-14 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.
Affected products
- publify/publify: before 9.2.10 — fixed in 9.2.10
How to fix
Upgrade to a fixed version: publify/publify 9.2.10. Check the vendor advisory for mitigations.
References
- https://github.com/publify/publify/commit/29a5837c29620e33857d7a5afce01384e3f8e41a
- https://huntr.dev/bounties/17d86a50-265c-4ec8-9592-0bd909ddc8f3
- https://github.com/publify/publify/commit/29a5837c29620e33857d7a5afce01384e3f8e41a
- https://huntr.dev/bounties/17d86a50-265c-4ec8-9592-0bd909ddc8f3
Get alerted when CVE-2022-1812 or the next vulnerability affects your stack