What’s Vulnerable › Vulnerabilities
CVE-2022-1820: Keep Backup Daily <= 2.0.2 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Keep Backup Daily plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘t’ parameter in versions up to, and including, 2.0.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- fahadmahmood Keep Backup Daily: before 2.0.3 — fixed in 2.0.3
How to fix
Upgrade to a fixed version: fahadmahmood Keep Backup Daily 2.0.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2727789%40keep-backup-daily&new=2727789%40keep-backup-daily&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/keep-backup-daily/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8693a8b1-15e1-4c9c-90fb-51fcaf5ff451?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1820
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2727789%40keep-backup-daily&new=2727789%40keep-backup-daily&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/keep-backup-daily/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8693a8b1-15e1-4c9c-90fb-51fcaf5ff451?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1820
Get alerted when CVE-2022-1820 or the next vulnerability affects your stack