What’s Vulnerable › Vulnerabilities
CVE-2022-1822: Zephyr Project Manager <= 3.2.40 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Zephyr Project Manager plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘project’ parameter in versions up to, and including, 3.2.40 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- Zephyr Project Manager Project Zephyr Project Manager: before 3.2.41 — fixed in 3.2.41
How to fix
Upgrade to a fixed version: Zephyr Project Manager Project Zephyr Project Manager 3.2.41. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2727947%40zephyr-project-manager&new=2727947%40zephyr-project-manager&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/zephyr-project-manager/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/22d50526-e21f-412d-9eed-b9b1f48c3358?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1822
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2727947%40zephyr-project-manager&new=2727947%40zephyr-project-manager&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/zephyr-project-manager/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/22d50526-e21f-412d-9eed-b9b1f48c3358?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1822
Get alerted when CVE-2022-1822 or the next vulnerability affects your stack