What’s Vulnerable › Vulnerabilities
CVE-2022-1825: Cross-site Scripting (XSS) - Reflected in collectiveaccess/providence
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository collectiveaccess/providence prior to 1.8.
Affected products
- collectiveaccess/providence: before 1.8 — fixed in 1.8
How to fix
Upgrade to a fixed version: collectiveaccess/providence 1.8. Check the vendor advisory for mitigations.
References
- https://github.com/collectiveaccess/providence/commit/49de453c8d4942d09fab230e8f242300c831e2a7
- https://huntr.dev/bounties/c6ad4cef-1b3d-472f-af0e-68e46341dfe5
- https://github.com/collectiveaccess/providence/commit/49de453c8d4942d09fab230e8f242300c831e2a7
- https://huntr.dev/bounties/c6ad4cef-1b3d-472f-af0e-68e46341dfe5
Get alerted when CVE-2022-1825 or the next vulnerability affects your stack