What’s Vulnerable › Vulnerabilities
CVE-2022-1845: WP Post Styling < 1.3.1 - Multiple CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Post Styling WordPress plugin before 1.3.1 does not have CSRF checks in various actions, which could allow attackers to make a logged in admin delete plugin's data, update the settings, add new entries and more via CSRF attacks
Affected products
- WP Post Styling: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: WP Post Styling 1.3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6ee3e9e2-ff57-41c4-8cc5-b258801a8a02
- https://wpscan.com/vulnerability/6ee3e9e2-ff57-41c4-8cc5-b258801a8a02
Get alerted when CVE-2022-1845 or the next vulnerability affects your stack