What’s Vulnerable › Vulnerabilities
CVE-2022-1886: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-26 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.
Affected products
- Fedoraproject Fedora: 35
- vim/vim: before 8.2.5016 — fixed in 8.2.5016
How to fix
Upgrade to a fixed version: vim/vim 8.2.5016. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/2a585c85013be22f59f184d49612074fd9b115d7
- https://huntr.dev/bounties/fa0ad526-b608-45b3-9ebc-f2b607834d6a
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TYNK6SDCMOLQJOI3B4AOE66P2G2IH4ZM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/2a585c85013be22f59f184d49612074fd9b115d7
- https://huntr.dev/bounties/fa0ad526-b608-45b3-9ebc-f2b607834d6a
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TYNK6SDCMOLQJOI3B4AOE66P2G2IH4ZM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-1886 or the next vulnerability affects your stack