What’s Vulnerable › Vulnerabilities
CVE-2022-1889: Newsletter < 7.4.6 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Newsletter WordPress plugin before 7.4.6 does not escape and sanitise the preheader_text setting, which could allow high privilege users to perform Stored Cross-Site Scripting attacks when the unfilteredhtml is disallowed
Affected products
- satollo Newsletter – Send awesome emails from WordPress: before 7.4.6 — fixed in 7.4.6
How to fix
Upgrade to a fixed version: satollo Newsletter – Send awesome emails from WordPress 7.4.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ee3832e2-ce40-4063-a23e-44c7f7f5f46a
- https://wpscan.com/vulnerability/ee3832e2-ce40-4063-a23e-44c7f7f5f46a
Get alerted when CVE-2022-1889 or the next vulnerability affects your stack