What’s Vulnerable › Vulnerabilities
CVE-2022-1896: underConstruction < 1.21 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The underConstruction WordPress plugin before 1.21 does not sanitise or escape the "Display a custom page using your own HTML" setting before outputting it, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiletred_html capability is disallowed.
Affected products
- underConstruction: before 1.21 — fixed in 1.21
How to fix
Upgrade to a fixed version: underConstruction 1.21. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3e8bd875-2435-4a15-8ee8-8a00882b499c
- https://wpscan.com/vulnerability/3e8bd875-2435-4a15-8ee8-8a00882b499c
Get alerted when CVE-2022-1896 or the next vulnerability affects your stack