What’s Vulnerable › Vulnerabilities
CVE-2022-1897: Out-of-bounds Write in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-27 · updated 2026-06-17
- Weakness: CWE-787
Description
Out-of-bounds Write in GitHub repository vim/vim prior to 8.2.
Affected products
- Apple macOS: before 13.0 — fixed in 13.0
- Debian Linux: 10.0
- Fedoraproject Fedora: 34, 35, 36
- vim/vim: before 8.0.5023 — fixed in 8.0.5023
How to fix
Upgrade to a fixed version: Apple macOS 13.0; vim/vim 8.0.5023. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/338f1fc0ee3ca929387448fe464579d6113fa76a
- https://huntr.dev/bounties/82c12151-c283-40cf-aa05-2e39efa89118
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OZSLFIKFYU5Y2KM5EJKQNYHWRUBDQ4GJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QMFHBC5OQXDPV2SDYA2JUQGVCPYASTJB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TYNK6SDCMOLQJOI3B4AOE66P2G2IH4ZM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
Get alerted when CVE-2022-1897 or the next vulnerability affects your stack