What’s Vulnerable › Vulnerabilities
CVE-2022-1898: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-27 · updated 2026-06-17
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 8.2.
Affected products
- Apple macOS: before 13.0 — fixed in 13.0
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34, 35, 36
- vim/vim: before 8.2.5024 — fixed in 8.2.5024
How to fix
Upgrade to a fixed version: Apple macOS 13.0; vim/vim 8.2.5024. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/e2fa213cf571041dbd04ab0329303ffdc980678a
- https://huntr.dev/bounties/45aad635-c2f1-47ca-a4f9-db5b25979cea
- https://lists.debian.org/debian-lts-announce/2022/06/msg00014.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OZSLFIKFYU5Y2KM5EJKQNYHWRUBDQ4GJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QMFHBC5OQXDPV2SDYA2JUQGVCPYASTJB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TYNK6SDCMOLQJOI3B4AOE66P2G2IH4ZM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213488
Get alerted when CVE-2022-1898 or the next vulnerability affects your stack