What’s Vulnerable › Vulnerabilities
CVE-2022-1901
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-19 · updated 2026-06-17
- Weakness: CWE-269
Description
In affected versions of Octopus Deploy it is possible to unmask sensitive variables by using variable preview.
Affected products
- Octopus Deploy Octopus Server: from 2019.1.0 through 2019.7.3; from 2020.1.0 through 2020.6.5449; from 2021.1.6959 through 2021.3.13021; from 2022.1.0 before 2022.1.3009; from 2022.2.6729 before 2022.2.7244; from 2022.3.348 before 2022.3.4953 — fixed in 2022.1.3009, 2022.2.7244, 2022.3.4953
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.1.3009, 2022.2.7244, 2022.3.4953. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-09/
- https://advisories.octopus.com/post/2022/sa2022-09/
Get alerted when CVE-2022-1901 or the next vulnerability affects your stack