What’s Vulnerable › Vulnerabilities
CVE-2022-1908: Buffer Over-read in bfabiszewski/libmobi
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-27 · updated 2026-06-17
- Weakness: CWE-126
Description
Buffer Over-read in GitHub repository bfabiszewski/libmobi prior to 0.11.
Affected products
- bfabiszewski/libmobi: before 0.11 — fixed in 0.11
How to fix
Upgrade to a fixed version: bfabiszewski/libmobi 0.11. Check the vendor advisory for mitigations.
References
- https://github.com/bfabiszewski/libmobi/commit/1e0378e6f9e4ae415cedc9eb10850888897c5dba
- https://huntr.dev/bounties/a7436e88-0488-4bd4-816f-2e2c803e93e8
- https://github.com/bfabiszewski/libmobi/commit/1e0378e6f9e4ae415cedc9eb10850888897c5dba
- https://huntr.dev/bounties/a7436e88-0488-4bd4-816f-2e2c803e93e8
Get alerted when CVE-2022-1908 or the next vulnerability affects your stack