What’s Vulnerable › Vulnerabilities
CVE-2022-1920
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-19 · updated 2026-06-17
- Weakness: CWE-122
Description
Integer overflow in matroskademux element in gst_matroska_demux_add_wvpk_header function which allows a heap overwrite while parsing matroska files. Potential for arbitrary code execution through heap overwrite.
Affected products
- Debian Linux: 10.0, 11.0
- GStreamer: before 1.20.3 — fixed in 1.20.3
How to fix
Upgrade to a fixed version: GStreamer 1.20.3. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1226
- https://lists.debian.org/debian-lts-announce/2022/08/msg00001.html
- https://www.debian.org/security/2022/dsa-5204
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1226
- https://lists.debian.org/debian-lts-announce/2022/08/msg00001.html
- https://www.debian.org/security/2022/dsa-5204
Get alerted when CVE-2022-1920 or the next vulnerability affects your stack