What’s Vulnerable › Vulnerabilities
CVE-2022-1927: Buffer Over-read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-29 · updated 2026-06-17
- Weakness: CWE-126
Description
Buffer Over-read in GitHub repository vim/vim prior to 8.2.
Affected products
- Apple macOS: before 13.0 — fixed in 13.0
- Fedoraproject Fedora: 34, 35, 36
- vim/vim: before 8.2.5037 — fixed in 8.2.5037
How to fix
Upgrade to a fixed version: Apple macOS 13.0; vim/vim 8.2.5037. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/4d97a565ae8be0d4debba04ebd2ac3e75a0c8010
- https://huntr.dev/bounties/945107ef-0b27-41c7-a03c-db99def0e777
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OZSLFIKFYU5Y2KM5EJKQNYHWRUBDQ4GJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QMFHBC5OQXDPV2SDYA2JUQGVCPYASTJB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TYNK6SDCMOLQJOI3B4AOE66P2G2IH4ZM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
Get alerted when CVE-2022-1927 or the next vulnerability affects your stack