What’s Vulnerable › Vulnerabilities
CVE-2022-1928: Cross-site Scripting (XSS) - Stored in go-gitea/gitea
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository go-gitea/gitea prior to 1.16.9.
Affected products
- Gitea Open Source Git Server: before 1.16.9 — fixed in 1.16.9
How to fix
Upgrade to a fixed version: Gitea Open Source Git Server 1.16.9. Check the vendor advisory for mitigations.
References
- https://github.com/go-gitea/gitea/commit/65e0688a5c9dacad50e71024b7529fdf0e3c2e9c
- https://huntr.dev/bounties/6336ec42-5c4d-4f61-ae38-2bb539f433d2
- https://security.gentoo.org/glsa/202210-14
- https://github.com/go-gitea/gitea/commit/65e0688a5c9dacad50e71024b7529fdf0e3c2e9c
- https://huntr.dev/bounties/6336ec42-5c4d-4f61-ae38-2bb539f433d2
- https://security.gentoo.org/glsa/202210-14
Get alerted when CVE-2022-1928 or the next vulnerability affects your stack