What’s Vulnerable › Vulnerabilities
CVE-2022-1931: Incorrect Synchronization in polonel/trudesk
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-31 · updated 2026-06-17
- Weakness: CWE-821
Description
Incorrect Synchronization in GitHub repository polonel/trudesk prior to 1.2.3.
Affected products
- polonel/trudesk: before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: polonel/trudesk 1.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/polonel/trudesk/commit/314540864dbf2c0eaa99aa42c3d317de9501eb67
- https://huntr.dev/bounties/50c4cb63-65db-41c5-a16d-0560d7131fde
- https://github.com/polonel/trudesk/commit/314540864dbf2c0eaa99aa42c3d317de9501eb67
- https://huntr.dev/bounties/50c4cb63-65db-41c5-a16d-0560d7131fde
Get alerted when CVE-2022-1931 or the next vulnerability affects your stack