What’s Vulnerable › Vulnerabilities
CVE-2022-1933: CDI < 5.1.9 - Reflected Cross-Site-Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The CDI WordPress plugin before 5.1.9 does not sanitise and escape a parameter before outputting it back in the response of an AJAX action (available to both unauthenticated and authenticated users), leading to a Reflected Cross-Site Scripting
Affected products
- CDI – Collect and Deliver Interface for Woocommerce: before 5.1.9 — fixed in 5.1.9
How to fix
Upgrade to a fixed version: CDI – Collect and Deliver Interface for Woocommerce 5.1.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6cedb27f-6140-4cba-836f-63de98e521bf
- https://wpscan.com/vulnerability/6cedb27f-6140-4cba-836f-63de98e521bf
Get alerted when CVE-2022-1933 or the next vulnerability affects your stack