What’s Vulnerable › Vulnerabilities

CVE-2022-1936

Description

Incorrect authorization in GitLab EE affecting all versions from 12.0 before 14.9.5, all versions starting from 14.10 before 14.10.4, all versions starting from 15.0 before 15.0.1 allowed an attacker already in possession of a valid Project Deploy Token to misuse it from any location even when IP address restrictions were configured

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.10.4, 14.9.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-1936 or the next vulnerability affects your stack