What’s Vulnerable › Vulnerabilities

CVE-2022-1941: Out of Memory issue in ProtocolBuffers for cpp and python

Description

A parsing vulnerability for the MessageSet type in the ProtocolBuffers versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 3.21.5 for protobuf-cpp, and versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 4.21.5 for protobuf-python can lead to out of memory failures. A specially crafted message with multiple key-value per elements creates parsing issues, and can lead to a Denial of Service against services receiving unsanitized input. We recommend upgrading to versions 3.18.3, 3.19.5, 3.20.2, 3.21.6 for protobuf-cpp and 3.18.3, 3.19.5, 3.20.2, 4.21.6 for protobuf-python. Versions for 3.16 and 3.17 are no longer updated.

Affected products

How to fix

Upgrade to a fixed version: Google LLC protobuf-cpp 3.18.3, 3.19.5, 3.20.2, 3.21.6; protocolbuffers Python-Protobuf 3.18.3, 3.19.5, 3.20.2, 4.21.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-1941 or the next vulnerability affects your stack