What’s Vulnerable › Vulnerabilities
CVE-2022-1942: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-31 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.
Affected products
- Apple macOS: before 13.0 — fixed in 13.0
- Debian Linux: 10.0
- Fedoraproject Fedora: 35
- vim/vim: before 8.2.5043 — fixed in 8.2.5043
How to fix
Upgrade to a fixed version: Apple macOS 13.0; vim/vim 8.2.5043. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/71223e2db87c2bf3b09aecb46266b56cda26191d
- https://huntr.dev/bounties/67ca4d3b-9175-43c1-925c-72a7091bc071
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TYNK6SDCMOLQJOI3B4AOE66P2G2IH4ZM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/71223e2db87c2bf3b09aecb46266b56cda26191d
Get alerted when CVE-2022-1942 or the next vulnerability affects your stack