What’s Vulnerable › Vulnerabilities

CVE-2022-1944

Description

When the feature is configured, improper authorization in the Interactive Web Terminal in GitLab CE/EE affecting all versions from 11.3 prior to 14.9.5, 14.10 prior to 14.10.4, and 15.0 prior to 15.0.1 allows users with the Developer role to open terminals on other Developers' running jobs

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.10.4, 14.9.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-1944 or the next vulnerability affects your stack