What’s Vulnerable › Vulnerabilities
CVE-2022-1946: Gallery < 2.0.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gallery WordPress plugin before 2.0.0 does not sanitise and escape a parameter before outputting it back in the response of an AJAX action (available to both unauthenticated and authenticated users), leading to a Reflected Cross-Site Scripting issue
Affected products
- wpdevart Responsive Image Gallery, Gallery Album: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: wpdevart Responsive Image Gallery, Gallery Album 2.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0903920c-be2e-4515-901f-87253eb30940
- https://wpscan.com/vulnerability/0903920c-be2e-4515-901f-87253eb30940
Get alerted when CVE-2022-1946 or the next vulnerability affects your stack