What’s Vulnerable › Vulnerabilities
CVE-2022-1947: Use of Incorrect Operator in polonel/trudesk
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-31 · updated 2026-06-17
- Weakness: CWE-480
Description
Use of Incorrect Operator in GitHub repository polonel/trudesk prior to 1.2.3.
Affected products
- polonel/trudesk: before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: polonel/trudesk 1.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/polonel/trudesk/commit/a9e38f25c2af2722dee4fdafb2fb70d30d5106c5
- https://huntr.dev/bounties/cb4d0ab3-51ba-4a42-9e38-ac0e544266f1
- https://github.com/polonel/trudesk/commit/a9e38f25c2af2722dee4fdafb2fb70d30d5106c5
- https://huntr.dev/bounties/cb4d0ab3-51ba-4a42-9e38-ac0e544266f1
Get alerted when CVE-2022-1947 or the next vulnerability affects your stack