What’s Vulnerable › Vulnerabilities
CVE-2022-1951: Core Plugin for Kitestudio Themes < 2.3.1 - Reflected Cross-Site-Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The core plugin for kitestudio WordPress plugin before 2.3.1 does not sanitise and escape some parameters before outputting them back in a response of an AJAX action, available to both unauthenticated and authenticated users when a premium theme from the vendor is active, leading to a Reflected Cross-Site Scripting.
Affected products
- core plugin for kitestudio themes: before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: core plugin for kitestudio themes 2.3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f56f7244-e8ec-4a87-9419-643bc13b45a0
- https://wpscan.com/vulnerability/f56f7244-e8ec-4a87-9419-643bc13b45a0
Get alerted when CVE-2022-1951 or the next vulnerability affects your stack