What’s Vulnerable › Vulnerabilities
CVE-2022-1953: Product Configurator for WooCommerce < 1.2.32 - Unauthenticated Arbitrary File Deletion
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-22
Description
The Product Configurator for WooCommerce WordPress plugin before 1.2.32 suffers from an arbitrary file deletion vulnerability via an AJAX action, accessible to unauthenticated users, which accepts user input that is being used in a path and passed to unlink() without validation first
Affected products
- Product Configurator for WooCommerce: before 1.2.32 — fixed in 1.2.32
How to fix
Upgrade to a fixed version: Product Configurator for WooCommerce 1.2.32. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b66d6682-edbc-435f-a73a-dced32a32770
- https://wpscan.com/vulnerability/b66d6682-edbc-435f-a73a-dced32a32770
Get alerted when CVE-2022-1953 or the next vulnerability affects your stack