What’s Vulnerable › Vulnerabilities
CVE-2022-1957: Comment License < 1.4.0 - Arbitrary Settings Update via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-11 · updated 2026-06-17
- Weakness: CWE-352
Description
The Comment License WordPress plugin before 1.4.0 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack
Affected products
- Comment License: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Comment License 1.4.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ad3f6f3d-e12c-4867-906c-73aa001c7351
- https://wpscan.com/vulnerability/ad3f6f3d-e12c-4867-906c-73aa001c7351
Get alerted when CVE-2022-1957 or the next vulnerability affects your stack