What’s Vulnerable › Vulnerabilities
CVE-2022-1961: Google Tag Manager for WordPress (GTM4WP) <= 1.15.1 - Stored Cross-Site Scripting via Content Element ID
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Google Tag Manager for WordPress (GTM4WP) plugin is vulnerable to Stored Cross-Site Scripting due to insufficient escaping via the `gtm4wp-options[scroller-contentid]` parameter found in the `~/public/frontend.php` file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.15.1. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.
Affected products
- duracelltomi GTM4WP – A Google Tag Manager (GTM) plugin for WordPress: before 1.15.2 — fixed in 1.15.2
How to fix
Upgrade to a fixed version: duracelltomi GTM4WP – A Google Tag Manager (GTM) plugin for WordPress 1.15.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Xib3rR4dAr/02a21cd0ea0b7bf586131c5eebb69f1d
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2732977%40duracelltomi-google-tag-manager&new=2732977%40duracelltomi-google-tag-manager&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/duracelltomi-google-tag-manager/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/202c14d0-9207-47cb-9410-ca4c70d7b6d2?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1961
- https://gist.github.com/Xib3rR4dAr/02a21cd0ea0b7bf586131c5eebb69f1d
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2732977%40duracelltomi-google-tag-manager&new=2732977%40duracelltomi-google-tag-manager&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/duracelltomi-google-tag-manager/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/202c14d0-9207-47cb-9410-ca4c70d7b6d2?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1961
Get alerted when CVE-2022-1961 or the next vulnerability affects your stack