What’s Vulnerable › Vulnerabilities
CVE-2022-1964: Easy SVG Support < 3.3.0 - Author+ Stored Cross Site Scripting via SVG
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy SVG Support WordPress plugin before 3.3.0 does not sanitise uploaded SVG files, which could allow users with a role as low as Author to upload a malicious SVG containing XSS payloads
Affected products
- Easy SVG Support: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: Easy SVG Support 3.3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/52cf7e3c-2a0c-45c4-be27-be87424f1338
- https://wpscan.com/vulnerability/52cf7e3c-2a0c-45c4-be27-be87424f1338
Get alerted when CVE-2022-1964 or the next vulnerability affects your stack