What’s Vulnerable › Vulnerabilities
CVE-2022-1976
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-31 · updated 2026-06-17
- Weakness: CWE-416
Description
A flaw was found in the Linux kernel’s implementation of IO-URING. This flaw allows an attacker with local executable permission to create a string of requests that can cause a use-after-free flaw within the kernel. This issue leads to memory corruption and possible privilege escalation.
Affected products
- Linux kernel: from 5.17.3 before 5.18.6 — fixed in 5.18.6
How to fix
Upgrade to a fixed version: Linux kernel 5.18.6. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2092549
- https://security.netapp.com/advisory/ntap-20230214-0005/
- https://bugzilla.redhat.com/show_bug.cgi?id=2092549
- https://security.netapp.com/advisory/ntap-20230214-0005/
Get alerted when CVE-2022-1976 or the next vulnerability affects your stack