What’s Vulnerable › Vulnerabilities
CVE-2022-1981
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-01 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue has been discovered in GitLab EE affecting all versions starting from 12.2 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1. In GitLab, if a group enables the setting to restrict access to users belonging to specific domains, that allow-list may be bypassed if a Maintainer uses the 'Invite a group' feature to invite a group that has members that don't comply with domain allow-list.
Affected products
- GitLab: from 12.2.0 before 14.10.5; from 15.0.0 before 15.0.4; 15.1.0 — fixed in 14.10.5, 15.0.4
How to fix
Upgrade to a fixed version: GitLab 14.10.5, 15.0.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1981.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/354791
- https://hackerone.com/reports/1501733
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1981.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/354791
- https://hackerone.com/reports/1501733
Get alerted when CVE-2022-1981 or the next vulnerability affects your stack