What’s Vulnerable › Vulnerabilities
CVE-2022-1990: Nested Pages < 3.1.21 - Admin+ Stored Cross Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Nested Pages WordPress plugin before 3.1.21 does not escape and sanitize the some of its settings, which could allow high privilege users to perform Stored Cross-Site Scripting attacks when the unfiltered_html is disallowed
Affected products
- Nested Pages: before 3.1.21 — fixed in 3.1.21
How to fix
Upgrade to a fixed version: Nested Pages 3.1.21. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/42f1bf1f-95a8-41ee-a637-88deb80ab870
- https://wpscan.com/vulnerability/42f1bf1f-95a8-41ee-a637-88deb80ab870
Get alerted when CVE-2022-1990 or the next vulnerability affects your stack