What’s Vulnerable › Vulnerabilities
CVE-2022-1994: Google Authenticator < 1.0.8 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Login With OTP Over SMS, Email, WhatsApp and Google Authenticator WordPress plugin before 1.0.8 does not escape its settings, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed
Affected products
- Login With OTP Over SMS, Email, WhatsApp and Google Authenticator: before 1.0.8 — fixed in 1.0.8
How to fix
Upgrade to a fixed version: Login With OTP Over SMS, Email, WhatsApp and Google Authenticator 1.0.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/114d94be-b567-4b4b-9a44-f2c05cdbe18e
- https://wpscan.com/vulnerability/114d94be-b567-4b4b-9a44-f2c05cdbe18e
Get alerted when CVE-2022-1994 or the next vulnerability affects your stack