What’s Vulnerable › Vulnerabilities
CVE-2022-1995: miniOrange's Malware Scanner < 4.5.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Malware Scanner WordPress plugin before 4.5.2 does not sanitise and escape some of its settings, leading to malicious users with administrator privileges to store malicious Javascript code leading to Cross-Site Scripting attacks when unfiltered_html is disallowed (for example in multisite setup)
Affected products
- miniorange Malware Scanner: before 4.5.2 — fixed in 4.5.2
How to fix
Upgrade to a fixed version: miniorange Malware Scanner 4.5.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/62fb399d-3327-45d0-b10f-769d2d164903
- https://wpscan.com/vulnerability/62fb399d-3327-45d0-b10f-769d2d164903
Get alerted when CVE-2022-1995 or the next vulnerability affects your stack