What’s Vulnerable › Vulnerabilities
CVE-2022-1997: Cross-site Scripting (XSS) - Stored in francoisjacquet/rosariosis
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository francoisjacquet/rosariosis prior to 9.0.
Affected products
- francoisjacquet/rosariosis: before 9.0 — fixed in 9.0
How to fix
Upgrade to a fixed version: francoisjacquet/rosariosis 9.0. Check the vendor advisory for mitigations.
References
- https://github.com/francoisjacquet/rosariosis/commit/6b22c0b5b40fad891c8cf9e7eeff3e42a35c0bf8
- https://huntr.dev/bounties/28861ae9-7b09-45b7-a003-eccf903db71d
- https://github.com/francoisjacquet/rosariosis/commit/6b22c0b5b40fad891c8cf9e7eeff3e42a35c0bf8
- https://huntr.dev/bounties/28861ae9-7b09-45b7-a003-eccf903db71d
Get alerted when CVE-2022-1997 or the next vulnerability affects your stack