What’s Vulnerable › Vulnerabilities
CVE-2022-2000: Out-of-bounds Write in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-09 · updated 2026-06-17
- Weakness: CWE-787
Description
Out-of-bounds Write in GitHub repository vim/vim prior to 8.2.
Affected products
- Apple macOS: before 11.7; from 12.0 before 12.6 — fixed in 11.7, 12.6
- Debian Linux: 10.0
- Fedoraproject Fedora: 35
- vim/vim: before 8.2.5063 — fixed in 8.2.5063
How to fix
Upgrade to a fixed version: Apple macOS 11.7, 12.6; vim/vim 8.2.5063. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/43
- http://seclists.org/fulldisclosure/2022/Oct/45
- https://github.com/vim/vim/commit/44a3f3353e0407e9fffee138125a6927d1c9e7e5
- https://huntr.dev/bounties/f61a64e2-d163-461b-a77e-46ab38e021f0
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4JJNUS4AEVYSEJMCK6JZB57QHD5V2G4O/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213443
- https://support.apple.com/kb/HT213444
Get alerted when CVE-2022-2000 or the next vulnerability affects your stack